Cannot migrate Postgres to metal volume EU Amsterdam -
vitakili
PROOP

2 years ago

"Cannot migrate volumes between non-metal and metal regions. Please create a new volume instead"

Solved

17 Replies

vitakili
PROOP

2 years ago

85adf73f-9ab0-4bc8-a052-82014314e290


kampouse
HOBBY

2 years ago

check the setting there are feature flag for that


kampouse
HOBBY

2 years ago

1350923234677096548


vitakili
PROOP

2 years ago

I already have that allowed


2 years ago

For some odd reason, some users are not able to migrate non-metal volumes to metal. I have escalated this issue to team in another thread.


vitakili
PROOP

2 years ago

Ah, so something I cannot make work on myself? Thanks a lot for your reply


verbosus
PRO

2 years ago

Same here. The feature flag is on, but I cannot migrate with the same message: "Cannot migrate volumes between non-metal and metal regions. Please create a new volume instead."


2 years ago

Apologies for the late response, non metal to metal volume migrations are currently paused for pro users. More on that can be found in the latest changelog: https://railway.com/changelog/2025-03-14-ssh-railpack-improvements#hobby-metal-volumes.


2 years ago

@uxuz When will this be unpaused?


2 years ago

Hey @Furiae, unfortunately I am unable to provide you with an exact date. However, what I can do is to notify everyone that has participated in this thread once non metal to metal volume migrations have been resumed for pro users.


2 years ago

That works for me. I have small demo environments at the moment so I am not in a huge rush. I do have a new app I am about to start building that we do not want to GCP or AWS which is why I am really checking. 😄


lenasi
PRO

2 years ago

Same error here. But I managed to create a new volume on metal, but impossible to import database dump from the previous non metal volume - pg_restore: error: could not execute query: ERROR: unrecognized configuration parameter "transaction_timeout"


fast-js
HOBBY

2 years ago

help me ,sad

Attachments


2 years ago

Hey everyone, metal volume migrations have been enabled for pro users under the metal volumes feature flag: https://railway.com/account/feature-flags. More on this can be found in the latest changelog: https://railway.com/changelog/2025-03-28-preferred-deployment-region#metal-feature-parity-+-migration-timeline

@volemrdat @Furiae


vitakili
PROOP

2 years ago

Olalala it works now, thanks for notifying


2 years ago

You are welcome! 🙂


2 years ago

!s


Status changed to Solved uxuz • over 1 year ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...