Free plan deployment says Serverless is disabled, but it is enabled
mamo-beatz-cell
FREEOP

9 days ago

Hi, I’m on the Free plan and my deployment keeps failing with this error:

“Free plan deployments must be serverless. Please go to your service settings and turn on the serverless flag.”

However, Enable Serverless is already turned ON in my service settings.

I turned Serverless OFF and back ON again and then started a new redeploy. The build completes successfully, but the Deploy stage does not start and I receive the same Serverless error again.

Could you please check why Railway is not recognizing the Serverless setting?

Service: Briefklar

Environment: production

Solved

1 Replies

Railway
BOT

9 days ago

Serverless is enabled on Briefklar in production. Keep it on, and start a new deploy from the command palette instead of redeploying: press Ctrl+K (Cmd+K on Mac), then select Deploy latest commit.


Status changed to Awaiting User Response Railway • 9 days ago


Railway
BOT

2 days ago

This thread has been marked as solved automatically due to a lack of recent activity. Please re-open this thread or create a new one if you require further assistance. Thank you!

Status changed to Solved Railway • 1 day ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...