2 hours ago
I am trying to generate a public domain for my frontend service in the PR environment. It fails with following message: Error adding service domain
Failed to create service domain, please try again.
What exactly is the problem? Some configuration that I am missing?
My production service has a generated domain as well.
2 Replies
Status changed to Awaiting Railway Response Railway • about 2 hours ago
an hour ago
The domain creation is failing because Railway combines your service and PR environment names into a hostname that exceeds the 63-character limit. Our domain generator should handle that, and the error message should explain it.
As a workaround, shorten the PR environment name to something like pr-2, then try generating the domain again.
Status changed to Awaiting User Response Railway • about 1 hour ago
sam-a
The domain creation is failing because Railway combines your service and PR environment names into a hostname that exceeds the 63-character limit. Our domain generator should handle that, and the error message should explain it. As a workaround, shorten the PR environment name to something like `pr-2`, then try generating the domain again.
an hour ago
Works! Thank you
Status changed to Awaiting Railway Response Railway • about 1 hour ago
Status changed to Solved katarinalang • about 1 hour ago