a month ago
My Service alkam-md has an Express HTTP server that starts successfully (logs confirm) but returns 502 "train has not arrived" on both service domain and custom domain. The server accepts background webhooks but HTTP requests fail. Need platform-level investigation of edge routing for this service on port 3000.
Deployment: 5ec2cc57 (SUCCESS)
Error: 502 Not Found - The train has not arrived at the station
4 Replies
a month ago
This thread has been opened as a bounty so the community can help solve it.
Status changed to Open Railway • about 1 month ago
a month ago
Make sure you bind the address to 0.0.0.0 and the Custom Domain and Service Domain port is set to the PORT your app is listening to
mayori
Make sure you bind the address to `0.0.0.0` and the Custom Domain and Service Domain port is set to the PORT your app is listening to
a month ago
I've configured it like you said from the start, but it's still the same, nothing different
I've configured it like you said from the start, but it's still the same, nothing different
a month ago
Try having the server listen to an arbitrary port (eg, 4100) and change port the URL is mapped to as well.
a month ago
There is no really right solution. However, this problem has been resolved by deleting and re-adding custom domains with the same port along with the same domain, strange but successful