I keep hitting a High Memory usage on my Hermes Deploy
toddhopper1972
PROOP

a month ago

I had the issue over the weekend and thought it was fixed as an admin suggested I redeploy my Hermes. I have the limit set at 24 gig and I am using under 3 gig. I need help in getting this fixed permanently.

image.png

Attachments

Solved$20 Bounty

Pinned Solution

toddhopper1972
PROOP

a month ago

I think I fixed it myself. I did a google search and found out that Hermes Agent had a node.js limit that could be triggering the issue. I added a new variable NODE_OPTIONS and the value as --max_old_space_size=16384. So far it seems to have worked. I am running it pretty hard and have exceeded 2.3 gig with no error. Yay me!!!

13 Replies

toddhopper1972
PROOP

a month ago

image.png

Attachments


Railway
BOT

a month ago

Your screenshot shows the warning "memory limit (1.2 GB) reached," which is a per-replica memory cap set on the service itself, not the 24 GB workspace plan maximum you may be looking at. You can adjust this in your service's Settings under Deploy > Replica Limits.


Status changed to Awaiting User Response Railway • 26 days ago


toddhopper1972
PROOP

a month ago

I have the replica limits set as high as they will go

image.png

Attachments


Status changed to Awaiting Railway Response Railway • 26 days ago


Railway
BOT

a month ago

This thread has been opened as a bounty so the community can help solve it.

Status changed to Open Railway • 26 days ago


a month ago

You might need to redeploy after increasing the maximum vCPUs and Memory


mayori

You might need to redeploy after increasing the maximum vCPUs and Memory

toddhopper1972
PROOP

a month ago

I did redeploy it Saturday and the error message went away. Then it came back again today.


toddhopper1972
PROOP

a month ago

Also, when I hover over the chart, it shows that I have 24 gig available and I am only using up to 3 gig. Its like the red line is stuck and causing the error.


a month ago

If it's Redeploying the latest deployment, it is probably using the same configuration of the latest deployment (before memory increasing), Try Redeploy Source Image from the Command Palette (Ctrl+K)


mayori

If it's Redeploying the latest deployment, it is probably using the same configuration of the latest deployment (before memory increasing), Try Redeploy Source Image from the Command Palette (Ctrl+K)

toddhopper1972
PROOP

a month ago

Ok, I am very new at this and I am old :) ....would you mind giving me a brief walkthrough of where I need to click and run the Ctrl-K, I am not sure where the Command Palette is.


toddhopper1972

Ok, I am very new at this and I am old :) ....would you mind giving me a brief walkthrough of where I need to click and run the Ctrl-K, I am not sure where the Command Palette is.

toddhopper1972
PROOP

a month ago

I figured out where to run Ctrl-K and re-deployed the source image. It re-deployed successfully and I logged out and back in. The high memory error limit is still there. Anything else I should try?


mayori

If it's Redeploying the latest deployment, it is probably using the same configuration of the latest deployment (before memory increasing), Try Redeploy Source Image from the Command Palette (Ctrl+K)

toddhopper1972
PROOP

a month ago

I actually changed the region and re-deployed my Hermes and I am still having the High Memory Usage error. So frustrated.....


toddhopper1972
PROOP

a month ago

I think I fixed it myself. I did a google search and found out that Hermes Agent had a node.js limit that could be triggering the issue. I added a new variable NODE_OPTIONS and the value as --max_old_space_size=16384. So far it seems to have worked. I am running it pretty hard and have exceeded 2.3 gig with no error. Yay me!!!


toddhopper1972
PROOP

a month ago

Spoke too soon. Same error is back......ughhhhh


toddhopper1972
PROOP

a month ago

Now I really fixed it. I was able to update the limit on the memory monitor! I edited it to 16Gig and the error went away immediately. Hope this helps someone else out.


Status changed to Solved toddhopper1972 • 26 days ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...