Postgres crash loop - Database connection timed out since Jun 12
odcmiguel-ship-it
HOBBYOP

3 months ago

Hi Railway team,

My Postgres service in project "miraculous-charisma" has been in a

persistent crash loop since June 12, 2026.

Restart and Redeploy attempts have all failed.

Symptoms:

  • Postgres crashes repeatedly every few minutes
  • Worker (n8n) logs show: "Database connection timed out" every 7 seconds
  • postgres-volume shows warning ⚠️ 1
  • Redis and Primary services remain Online

Project: miraculous-charisma

Region: US West

Plano: Hobby

Could you please check if the postgres-volume is corrupted or if

there is an issue preventing Postgres from starting correctly?

Thank you

Solved

1 Replies

Railway
BOT

3 months ago

Your Postgres volume is at 486 MB out of its 500 MB capacity (97% full), which is why Postgres keeps crashing. You can fix this by clicking on the postgres-volume in your project canvas, then using the Live Resize option to increase it (your Hobby plan supports up to 5 GB). After resizing, redeploy the Postgres service and it should start normally, which will also resolve the n8n connection timeouts.


Status changed to Awaiting User Response Railway • 3 months ago


Railway
BOT

3 months ago

This thread has been marked as solved automatically due to a lack of recent activity. Please re-open this thread or create a new one if you require further assistance. Thank you!

Status changed to Solved Railway • 3 months ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...