Postgres Prisma Authentication Error
sartiplay
HOBBYOP

2 years ago

I just setup a new railway Posgressql database instance.

And i wanted to push my Prisma Schema to it.

I copied the Database Public URL, wich has the password and user in it.

Im getting the following error tho:

Error: P1000: Authentication failed against database server at junction.proxy.rlwy.net, the provided database credentials for postgres are not valid.

Please make sure to provide valid database credentials for the database server at junction.proxy.rlwy.net.

Does anyone have an idea why that is?

Would realy appreciate the help, since this is my first time using Railway 👍

Solved

13 Replies

sartiplay
HOBBYOP

2 years ago

ProjectID: 2ffe7724-a696-4e97-9c47-4045fde91aab


sartiplay
HOBBYOP

2 years ago

And if i use the normal DatabaseURL i get this error:

Error: P1001: Can't reach database server at postgres.railway.internal:5432

Please make sure your database server is running at postgres.railway.internal:5432.


2 years ago

have you changed any variables on the postgres service?


sartiplay
HOBBYOP

2 years ago

I have not no should i?


2 years ago

nope, but the password was changed somehow, ive reverted it and you are good to go now


sartiplay
HOBBYOP

2 years ago

Ohh okay thank you very much 🙏


sartiplay
HOBBYOP

2 years ago

ill try it right nowe


sartiplay
HOBBYOP

2 years ago

Okay that worked thank you very much 🙏


sartiplay
HOBBYOP

2 years ago

i have one more question tho. is there a way for me to see the tables inside the Database ?


sartiplay
HOBBYOP

2 years ago

Ahh nvm found it


sartiplay
HOBBYOP

2 years ago

Thank you very much for the quick help 🙏 i appreciat it


2 years ago

no problem!


2 years ago

!s


Status changed to Solved brody • over 1 year ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...