Prometheus port not exposed from RabbitMQ service
Anonymous
PROOP

13 days ago

Hi,

I have RabbitMQ version 4.3.6 running in my environments and I have some inconsistent behaviour when it comes to exposing Prometheus metrics to other services in the same environment.

https://railway.com/deploy/rabbitmq

In testing environment I was able to enable the plugin and connect to it no problem, running on port 15692 no credentials.

But on staging same image and version I can see that Prometheus was enabled in the logs:

2026-09-23 07:17:28.171329+00:00 [info] <0.956.0> Server startup complete; 4 plugins started.

2026-09-23 07:17:28.171329+00:00 [info] <0.956.0> * rabbitmq_prometheus

2026-09-23 07:17:28.171329+00:00 [info] <0.956.0> * rabbitmq_management

2026-09-23 07:17:28.171329+00:00 [info] <0.956.0> * rabbitmq_management_agent

2026-09-23 07:17:28.171329+00:00 [info] <0.956.0> * rabbitmq_web_dispatch

2026-09-23 07:17:28.256694+00:00 [info] <0.10.0> Time to start RabbitMQ: 2497 ms

2026-09-23 07:17:28.118818+00:00 [info] <0.1015.0> Prometheus metrics: HTTP (non-TLS) listener started on port 15692

But my service can't find it?

[governor] failed to read queue depths: HTTPConnectionPool(host='rabbitmq-ggx.railway.internal', port=15692): Max retries exceeded with url: /metrics/detailed?family=queue_coarse_metrics (Caused by NewConnectionError("HTTPConnection(host='rabbitmq-ggx.railway.internal', port=15692): Failed to establish a new connection: [Errno 111] Connection refused"))

I've tried re-deploying, testing custom start command, with credentials without, internal vs external url. Nothing changes.

Solved$20 Bounty

1 Replies

Railway
BOT

13 days ago

This thread has been opened as a bounty so the community can help solve it.

Status changed to Open Railway • 13 days ago


Anonymous
PROOP

13 days ago

Thank you this worked perfectly!


Status changed to Solved milo • 13 days ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...