3 months ago
Hello,
In the previous free trial plan I got the Railway Storage Bucket to work with my app. After upgrade to Hobby plan I get error in it saying "Access denied. Please check bucket credentials and permissions." I tried regenerating creds and even created new bucket and it still does not connect.
How can I fix this?
20 Replies
3 months ago
This thread has been opened as a bounty so the community can help solve it.
Status changed to Open Railway • 3 months ago
mayori
Try redeploy service that uses reference variables to the bucket service
3 months ago
Yes I redeploed. Same error.
3 months ago
Where do you see that "Access Denied" error? is it on logs from a service that connected to the bucket or from the dashboard?
mayori
Where do you see that "Access Denied" error? is it on logs from a service that connected to the bucket or from the dashboard?
3 months ago
In Railways Dashboard, when I click on the Bucket Service under Files tab
3 months ago
Try force reload the dashboard, you have upgraded to hobby so it shouldn't affect bucket created after upgrade
da-kicks-87
In Railways Dashboard, when I click on the Bucket Service under Files tab
3 months ago
Try logging out and then login back to your account.
Check the updated bucket credentials are properly configured in variables.
Both the access key id and secret access key should be checked.
Also verify endpoint and region.
3 months ago
I have logged out and logged back in. I check the env variables for the frontend. They are referencing the buckets' credentials. The values are correct. Still not solved.
Attached is a screenshot of the error.
Attachments
3 months ago
Go to variables tab and ensure root credentials for MINIO_ROOT_USER and MINIO_ROOT_PASSWORD exactly match what storage engine expects.
In settings tab, if you can access the generated public network link, go to MinIO console directly. login and verify that a bucket named media-bucket-live is active
3 months ago
Is this settled? id like to know how to fix this as it happened to me as well
h701h
Go to variables tab and ensure root credentials for MINIO_ROOT_USER and MINIO_ROOT_PASSWORD exactly match what storage engine expects. In settings tab, if you can access the generated public network link, go to MinIO console directly. login and verify that a bucket named media-bucket-live is active
3 months ago
I'm not sure what MINIO_ROOT_USER is. I don't see it.
romper
Is this settled? id like to know how to fix this as it happened to me as well
3 months ago
No , I have not solved it. Was it working for you on the free plan?
Status changed to Awaiting User Response Railway • 3 months ago
da-kicks-87
No , I have not solved it. Was it working for you on the free plan?
3 months ago
Any updates?
Status changed to Awaiting Railway Response Railway • 3 months ago
mayori
Try regenerate the credentials again 
3 months ago
I have tried it multiple times. Still same error.
h701h
Any updates?
3 months ago
Still not solved. How do I get the Railway team to look at this? I am a paying customer.
h701h
Go to variables tab and ensure root credentials for MINIO_ROOT_USER and MINIO_ROOT_PASSWORD exactly match what storage engine expects. In settings tab, if you can access the generated public network link, go to MinIO console directly. login and verify that a bucket named media-bucket-live is active
3 months ago
This is the most reasonable thing to do now for you
3 months ago
Same error on my side, I have this open issue: https://station.railway.com/questions/bucket-credentials-are-not-generated-aft-d102636c
3 months ago
Hey, sorry for the long wait here. This was an issue on our side, nothing you could have fixed.
When your workspace was upgraded, the storage organization that backs your buckets was left in a suspended state with our storage provider, which caused the Access Denied errors regardless of credential regeneration or new buckets. We've reactivated it, and I've verified your bucket (media-bucket-live) is accessible again. Your existing credentials work as-is, no changes needed on your end.
Please give it a try and let us know if you hit any further issues.
Status changed to Awaiting User Response Railway • 3 months ago
sam-a
Hey, sorry for the long wait here. This was an issue on our side, nothing you could have fixed. When your workspace was upgraded, the storage organization that backs your buckets was left in a suspended state with our storage provider, which caused the Access Denied errors regardless of credential regeneration or new buckets. We've reactivated it, and I've verified your bucket (media-bucket-live) is accessible again. Your existing credentials work as-is, no changes needed on your end. Please give it a try and let us know if you hit any further issues.
3 months ago
Yes! My bucket works now. I have tested it. My app loads the images from the bucket too. Thank you for solving this!
On a somewhat related note. In terms of UI, shouldn't the bucket service also have a green "Online" indicator like the other services?
See screenshot:
Attachments
Status changed to Awaiting Railway Response Railway • 3 months ago
3 months ago
Glad it's working! Buckets are object storage, not running services with deployments, so they don't have a deployment lifecycle status like "Online." The size label (54.4 MB) is the indicator that the bucket exists and is active.
Status changed to Awaiting User Response Railway • 3 months ago
Status changed to Solved nico • 3 months ago
