Redis internal works in dev but not in prod
parmlalli
HOBBYOP

a year ago

I have a video queue service that calls Redis and works just fine in development. However, in production, I keep getting errors. The error is: getaddrinfo ENOTFOUND redis-jl7b.railway.internal. I have tried everything and get get it to work. I need to get this working so I can deploy my production app. Please help

Solved$10 Bounty

Pinned Solution

starphoneswebtech
PRO

a year ago

have you tried adding ?family=0 on the redis internal url?

5 Replies

Railway
BOT

a year ago

Hey there! We've found the following might help you get unblocked faster:

If you find the answer from one of these, please let us know by solving the thread!


a year ago

This thread has been marked as public for community involvement, as it does not contain any sensitive or personal information. Any further activity in this thread will be visible to everyone.

Status changed to Open brody 11 months ago


starphoneswebtech
PRO

a year ago

have you tried adding ?family=0 on the redis internal url?


marcblattmann
PRO

a year ago

Looks like your app can’t reach the internal Redis host. It’s a DNS issue. If you havent already try deploy your app inside the same Railway environment.


marcblattmann

Looks like your app can’t reach the internal Redis host. It’s a DNS issue. If you havent already try deploy your app inside the same Railway environment.

a year ago

Using the public URL is not a good solution.


parmlalli
HOBBYOP

a year ago

Hi Everyone, thanks for the quick replies. I tried @starphoneswebtech solution and it worked.


Status changed to Solved samgordon 11 months ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...