TLS Cert does not accepted by browser as valid
azakharko
HOBBYOP

3 months ago

  • Description: after configuration, adding custom domain and deployment my app in browser rendered as one with invalid TLS cert, while browser indicates cart as valid (it has correct Common Name (CN) with no wildcard symbol in it)
  • Error: https can not be used due to cert issue
  • Log: no errors in logs
  • Github: https://github.com/azakharko/bright_kids_api (private repo)
Solved$10 Bounty

Pinned Solution

  1. check if the pointing to right DNS records of railway
  2. clear local cache or use another browser to check

as far i can see "Your openssl output shows the certificate for api.brightkids.online is valid and the full chain is OK"

use this to check yourself: openssl s_client -connect api.brightkids.online:443 -servername api.brightkids.online

4 Replies

Railway
BOT

3 months ago

This thread has been opened as a bounty so the community can help solve it.

Status changed to Open Railway • 4 months ago


Can you share the domain you’re trying to add?


azakharko
HOBBYOP

3 months ago

api.brightkids.online


It may take up to a few hours (maybe even a day) for Railway to validate the DNS and issue certificates. If one isn't issued by then, try removing the domain from Railway and add it back after ~10-15 mins. Update DNS records as necessary.


  1. check if the pointing to right DNS records of railway
  2. clear local cache or use another browser to check

as far i can see "Your openssl output shows the certificate for api.brightkids.online is valid and the full chain is OK"

use this to check yourself: openssl s_client -connect api.brightkids.online:443 -servername api.brightkids.online


Status changed to Solved dev • 3 months ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...