Lost my data as billing plan for interrupted
praveenjoshua23
HOBBYOP

a year ago

I have lost all my data which was serving content to a live website, since billing was interrupted due to declined transaction. Is there any way to recover the instance of Directus and the Postgres DB?

Solved$10 Bounty

Pinned Solution

a year ago

Hey, we had an incident going so it wasn't possible for you to deploy at that time, please try again now as non-pro deploys have been enabled again. Make sure to deploy the Postgres database service first since the Directus service depends on it, which is most likely why the health check failed in your screenshot above.

7 Replies

Railway
BOT

a year ago

Hey there! We've found the following might help you get unblocked faster:

If you find the answer from one of these, please let us know by solving the thread!


a year ago

You haven't lost any data, your deployments are offline, I'll let the community help you with getting them back online.


a year ago

Hey, as Brody mentioned above, your data isn't gone. You just need to redeploy them via the dashboard since they got removed / went offline.


praveenjoshua23
HOBBYOP

a year ago

I tried redeploying but I'm unable to, here's how it looks:

I also get this message when that happens:

Pausing non-pro deploys as we catch up with github's post-incident webhook buildup.

Attachments


praveenjoshua23

I tried redeploying but I'm unable to, here's how it looks: ![](https://station-server.railway.com/attachments/att_01k74yyc07e8g8v940aeankck2) I also get this message when that happens: Pausing non-pro deploys as we catch up with github's post-incident webhook buildup.

a year ago

Hey, we had an incident going so it wasn't possible for you to deploy at that time, please try again now as non-pro deploys have been enabled again. Make sure to deploy the Postgres database service first since the Directus service depends on it, which is most likely why the health check failed in your screenshot above.


praveenjoshua23

I tried redeploying but I'm unable to, here's how it looks: ![](https://station-server.railway.com/attachments/att_01k74yyc07e8g8v940aeankck2) I also get this message when that happens: Pausing non-pro deploys as we catch up with github's post-incident webhook buildup.

a year ago

Hey, did you manage to redeploy the services?


praveenjoshua23
HOBBYOP

a year ago

Yes, Thank you for guiding me!


Status changed to Solved uxuz • 12 months ago


Welcome!

Sign in to your Railway account to join the conversation.

Loading...